2FA TOTP BUG with TOR no-javascript

I tried to activate 2FA TOTP on the TOR-no-javascript version of LocalMonero, but it didn’t worked. It showed the QR-Code but it wasn’t possible to verify it. Everytime when I clicked on verify (no input field was shown) I just was set back to the settings 2FA page and had to start over. I tried 5 times or so. And even tried different security settings in TOR-Browser: at first safest, second safer, at third standard. But it didn’t matter which security setting I chose so I had to activate 2FA on the clearnet site (with firefox this time).


We just tested in the Tor browser and everything seemed to have worked fine. Are you using the latest version of Tor browser? Please let us know your OS.

Hi, I’m using Tor-Browser 12.0 on Debian 11.5.

Do you mind showing us a screenshot of the page without the input field?

Hi Alex, as I wrote earlier I used Firefox to enable 2FA after it wasn’t possible with the Tor-Browser for me. I din’t took a screenshot when the problem occured.

Do you mind disabling your 2FA to reproduce the issue? Or register a new account on Tor and screenshot the issue if it happens again?

OK I will try it by registering a second account. Please give me some time to do so.

This time it worked with the second account with no problem in TOR without javascript on the security-setting safest. I have no clue why it wasn’t possible to do the exact same thing on the first account with TOR no-javascript. Strange. But thanks anyway alex and team.

1 Like